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 Introduction

Digimarc Watermarking Plug-in enables production designers and premedia professionals to create connected 
packaging by applying a watermark to packaging artwork with Digimarc digital watermark.

The Watermarking Plug-in lets you easily add binary watermarks to special substrates such as white ink. You can 
also use the Watermarking Plug-in to add multi-channel watermarks to CMYK artwork.

When applying watermarks, the Watermarking Plug-in uses a different set of technologies than our other tools do, 
like the Digimarc for Packaging Adobe Illustrator Extension and the Digmarc Barcode Plug-in for Photoshop. Don't 
try to use the Watermarking Plug-in to apply watermarks to artwork that has already been watermarked using 
another plug-in. To apply the watermark to additional elements in an artwork file, use the same tool used 
originally.

Essential Concepts
Digimarc Watermarking Plug-in enables you to apply a Digimarc digital watermark to artwork elements in an 
Adobe Illustrator file. Vector and raster artwork files are supported for watermarking without embedding the 
original artwork elements. The Watermarking Plug-in doesn't support linked or embedded objects.

The basic workflow is:

1 Create a digital twin using the Digimarc Illuminate Platform.

2 Add a digital watermark to the twin in Illuminate.

3 Reference the digital twin using the Digimarc Watermarking Plug-in to apply the watermark to the 
package artwork. See Apply a Watermark.

When you watermark an artwork element, the selected digital watermark is applied as an effect, enabling you to 
experiment with different parameters to achieve optimal readability with minimal watermark visibility. For more 
information on effects, see the  Adobe Illustrator documentation.

Before you print the package, use Digimarc Verify to confirm the watermark has been properly applied to the 
packaging artwork. See the Guide to Digimarc Verify for macOS for instructions.

Best Practice
As a general rule, we recommend you supply press-ready files to Digimarc Verify. Verify checks for a 
watermark in all separations and how they interact with one another. Not including colors or not setting 
proper transparencies could impact the results. Accurate color correction, trapping, overprints, and so 
on produce the most accurate coverage maps and Verify data (watermarked channels, application 
ratings, fidelity points, and so on).

System Requirements
The Watermarking Plug-in requires:

Multicore Intel processor with 64-bit support or ARM-based Apple silicon processor
macOS 12 (Monterey), macOS 13 (Ventura), or macOS 14 (Sonoma)
Adobe Illustrator 2022, 2023, or 2024
16 GB RAM
100 MB hard disk space available for installation
Internet connection and a Digimarc Illuminate account with at least one subscription that supports digital 
watermarks

https://digimarc.app/login
https://helpx.adobe.com/illustrator/how-to/image-effects-basics.html
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Document Conventions
Following are the standards and conventions used in this documentation. See the Glossary for terms related to 
digital watermarking.

Convention Description

Numeric format
The fractional part of a numeric value is represented by the period 
character, such as pi =~ 3.14

Elements in the user interface Formatting: Text in bold

Titles of panels and dialogs Formatting: Text in italics

User input (text that a user types) Formatting: Text in a monospace font

File and directory paths Formatting: Text in a monospace font

Variables or variable data Formatting: Text in italics, often within angle brackets (< >)

Install the Extension
Follow the Adobe Illustrator instructions for installing extensions.

1 Close Adobe Illustrator before installing the extension.

2 Double-click the downloaded .pkg file.

3 To install the Digimarc Watermarking Plug-in, you must accept the terms of the software license 
agreement. Click Agree to complete the installation.

To use the extension, navigate to Effect > Digimarc > Watermark. See Apply a Watermark.

Product Help
To see this guide within Illustrator, click the Help icon (  ) on any Watermarking Plug-in panel.

Digimarc Support
For help using the Watermarking Plug-in, contact support.

 Digimarc Support Website
Send email to Digimarc Support

https://help.digimarc.com/
mailto:support@digimarc.com
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 Sign In to Digimarc Illuminate

The first time you launch the Digimarc Watermarking Plug-in, you're prompted to sign in to the plug-in and to 
Digimarc Illuminate.

After you sign in, your credentials are stored. If you close Adobe Illustrator without signing out, the next time you 
open Illustrator and choose Effect > Digimarc > Watermark, the extension automatically signs into the 
Watermarking Plug-in and Illuminate using your stored credentials. To see the current user, right-click the green 
user icon (   ) on any Watermarking Plug-in dialog or panel.

Note
Your Illuminate account must have at least one subscription that supports digital watermarks, such as 
Illuminate, Validate Packaging, or Recycle.

To sign in:

1 When you choose Effect > Digimarc > Watermark, the Watermarking Plug-in Sign In dialog opens. 

2 Click Sign In. The Digimarc Illuminate Platform sign-in dialog opens.
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3 Enter the Email address and Password associated with your Illuminate account.

4 Click Continue.

5 The first time you sign in to Illuminate, you're asked to authorize the application to access your 
Illuminate account. To continue, click Accept.

If you have problems signing in, contact your Illuminate account administrator for help.

Next Step

After you've signed in, you can Apply a Watermark.

Sign Out of Illuminate
After completing your work, you can sign out of Illuminate or stay signed in. If you sign out, your stored credentials 
are removed and you must sign in again to continue working with digital watermarks.

To sign out:

1 Right-click the green user icon (   ) on any Watermarking Plug-in dialog or panel.

2 Click Sign Out. Your stored credentials are removed.
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 Apply a Watermark

The Digimarc Watermarking Plug-in enables you to apply a Digimarc digital watermark to one or more artwork
elements. 

Before You Begin

Sign In to Digimarc Illuminate with an account that has at least one subscription that supports digital watermarks, 
such as Illuminate, Validate Packaging, or Recycle.

If you're watermarking rasterized elements, be sure they meet the following minimum requirements:

• 300–900 DPI
• At least one side of an artwork element must meet or exceed 128px or 1.77in @300dpi 
• use all four process color channels

Note
The Watermarking Plug-in removes the watermark from raster elements that are resized smaller than 
the minimum dimensions.

To apply a watermark:

1 Open the Adobe Illustrator file (.ai) that contains the unmarked artwork to be watermarked.

2 Select the artwork element(s) to be watermarked. Each element is watermarked with the same digital twin.

Note
You can apply the watermark to multiple artwork elements at a time, but they must be of the 
same type. If you select a mix of raster and vector elements, the Watermarking Plug-in displays 
an error (see Troubleshooting). Select the vector and raster elements separately to perform the 
steps below.
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3 Navigate to Effect > Digimarc > Watermark. The Search dialog opens, enabling you specify the digital 
twin to apply.

4 Type the GTIN or other identifier into the Search input field. 
• Searches don't need to match entirely, but the search text must be an exact substring beginning 

with the first four characters of the identifier.

Tip
If you're using a GTIN shorter than 14 digits, Illuminate pads the identifier with leading 
zeros, but you don't need to enter them in the search field. For example, if your UPC-E or 
EAN-8 is 99991234 and the digital twin's GTIN is 00000099991234, searching for 9999 
returns the correct twin. Searching for 1234 does not.

• The search is case sensitive. Searching for ABCD produces different results than searching for 
abcd.

• You can search for a product's primary identifier, variant ID, or promotional asset ID.

5 Click Search.
• If one matching twin is found, the Details panel opens.
• If more than one matching twin is found, the Twin Select panel opens. Up to 25 twins are displayed. 

To narrow the results, click  Back and refine the search. Results could span any of the accounts 
to which you have access.
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Twin Select
Digital twins are listed in order by their creation date, with the most recently created twin at the top. The digital 
twin you select will be applied to all watermarked elements in the file.

1 Select a digital twin from the list.

If you don't see the desired twin, or if any of the details are incorrect:

1.1 Update the digital watermark information on the Illuminate Platform.
For instructions on creating and updating twins, refer to the user's guide for your Platform 
subscription.

1.2 Return to the plug-in and click  Back to search again.

2 Click Continue. The Details panel opens.
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Details
The Details panel displays the details for the selected digital twin. You choose the watermark resolution before 
setting the remaining watermarking options.

To set the resolution:

1 Click the option for the desired Watermark resolution. The watermark resolution is measured in 
watermarking elements (waxels) per inch (WPI) and can be set to 150 WPI (the default) or 75 WPI. The 
chosen resolution is preselected the next time you watermark an element in this file.

2 Review the details and click Confirm.

Note
After you confirm, the resolution can't be changed, even if you remove the effect and reapply it.

The Watermark Options panel opens. See Apply Watermark Options.

Apply Watermark Options
The Watermark Options dialog is where you set the pattern type or watermark strength and the corresponding 
options. The options vary, depending on whether the artwork element is vector or raster. Artwork for a package 
can contain both vector and raster elements, but the watermarks are applied differently.
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Vector Binary Options
These options are specific to the binary pattern watermark and a vector element. If you want a multi-channel 
watermark, use the Rasterized Options with a rasterized element.

1 Select the desired Pattern type. For more information about the pattern types, visit our  Center of 
Digimarc Education.

The left image was created using holes. The right image was created using dots.

Dots
Applies the watermark as dots of ink created by removing background from the artwork element(s).

Holes
Applies the watermark by removing dots (making holes) in the artwork element(s).

https://code.digimarc.com/
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2 Select the desired Dot density or Hole density. Density determines how close the dots or holes are 
together. Choices vary, depending on the WPI setting.

Waxels per inch Valid values Default

75 WPI 35, 40, 45 40

150 WPI 20, 25, 30 20

3 Select the desired Dot size or Hole size. The dot or hole size determines the size of the individual dots or 
holes. Choices vary, depending on the selected pattern type.

Pattern type Valid values Default

Dots 0.05mm–0.20mm 0.20mm

Holes 0.05mm–0.30mm 0.20mm

Note
For watermarks using 150 WPI, when the hole size is 0.25mm or greater, the maximum hole 
density is 20.

4 If you're watermarking white ink, enable the Watermark white ink option. For information on white ink 
watermarking, see the  Center of Digimarc Education.

5 Click OK. The Watermarking Plug-in applies the watermark to the artwork element(s).

Rasterized Options
These options are specific to the multi-channel watermark and a rasterized element. If you want a binary pattern 
watermark, use the Vector Binary Options with a vector element.

Note
Artwork elements must be rasterized using the Object > Rasterize menu option. See Troubleshooting.

https://code.digimarc.com/
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1 Multi-channel is the only Watermark technique currently supported.

2 Select the desired Strength in the range 1–10. The strength determines how visible and easily detectable 
the watermark is. The higher the number, the more visible it is.

3 Indicate whether you want to Watermark areas with only black ink. When selected, areas with only black 
pixels above minimum dot, such as drop shadows, will be watermarked.

4 For the Allow tint parameter, choose a color to add as a tint when no other viable ink is available above 
minimum dot. Options are:

• Off: Does not add tint to the element for watermarking
• Cyan: Adds a cyan tint to the element in which to place the watermark
• Yellow: Adds a yellow tint to the element in which to place the watermark
• Black: If Watermark areas with only black ink is enabled, adds a black tint to elements in which to 

place the watermark

5 Select the Minimum dot %. The default value is 2.

6 Click OK. The Watermarking Plug-in applies the watermark to the artwork element(s).
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Edit Watermark Options
To edit the options for a watermarked artwork element(s):

1 Select the desired artwork element(s).

2 Click the effect in the Appearance panel to open the relevant Watermark Options dialog.

3 Change the desired watermarking options as described in Raster Options or Vector Options.

Next Steps

Use Digimarc Verify to confirm the watermark has been properly applied to the packaging artwork. See the Guide 
to Digimarc Verify for macOS for instructions.
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 Known Limitations

When working with the Digimarc Watermarking Plug-in, keep these limitations in mind.

Plug-in Compatibility
The technologies used in the Digimarc for Packaging Adobe Illustrator Extension aren't compatible with those 
used in the Watermarking Plug-in. Don't try to apply watermarks to artwork elements that have already been 
watermarked using the other plug-in.

Gradients
For rasterized elements, digital watermarks might require a higher dot density setting to be reliably detected in 
gradients.

Gradients within vector elements are unsupported.

Workflows to Avoid After Watermarking
To avoid placing the artwork file in a state that exposes known issues, it's critical that designers complete the 
artwork design, layout, and layer structure before using the Watermarking Plug-in. Avoid the following post-
watermarking workflows:

• Color correction

• Unembedding watermarked links

• Embedding outside-watermarked links from other applications, such as Photoshop or the Digimarc for 
Packaging Adobe Illustrator Extension
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 Troubleshooting

If you see errors or are having trouble using the Watermarking Plug-in, consult this section for suggested 
remedies. If you need further assistance, see Product Help.

Unsupported Selection
You will see this error if you:

• select both raster and vector artwork elements to watermark in one operation

- Select only raster elements or vector elements before applying the watermark. Artwork for a 
package can contain both vector and raster elements, but the watermarks are applied differently. 
See Apply Watermark Options.

• try to watermark a raster element that's less than 300 DPI or greater than 900 DPI

- Increase or decrease the element's resolution before applying the watermark.

• try to watermark a raster element that's smaller than 128px or 1.77in @300dpi 

- Select artwork elements with at least one side that's 128px @72dpi = 533px or 1.77in or 45mm 
@300dpi. Raster elements smaller than that aren't supported.

• try to watermark a raster element that doesn't contain (CMYK) process colors

- To be watermarked, raster artwork elements must contain all four process color channels.

• try to watermark a group

- Double-click an element within the group to enter isolation mode. You can then apply the 
watermark to a single element in the group or multi-select elements to apply the watermark to them 
at one time.

- Alternatively, you can ungroup the elements before applying the watermark.

Watermark options cannot be applied to selected art type
You will see this error if you use the Effect > Apply Watermark option

• for a raster element after applying a watermark to a vector element

• for a vector element after applying a watermark to a raster element

Instead, choose Effect > Digimarc > Watermark and choose the watermark options for the selected artwork type.
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Watermark Conflict
You will see this error if you try to watermark a document with the Watermarking Plug-in that has already 
been watermarked using another Digimarc tool, such as the Digimarc for Packaging Adobe Illustrator Extension. 
See Known Limitations. To apply the watermark to additional artwork elements in the document, use the same 
tool that was initially used.

Watermark is missing after resizing an element
The Watermarking Plug-in removes the watermark from raster elements that are resized smaller than the minimum 
dimensions (128x128 pixels). Avoid resizing raster elements after applying the watermark, and ensure the 
minimum requirements are met for each. See Apply a Watermark.

Raster options aren't available for a rasterized element
To apply the raster watermarking options, be sure artwork elements were rasterized using the Object > Rasterize 
menu option. In Illustrator, the Effect > Rasterize option is a non-destructive simulation that doesn't actually 
rasterize the element; it's still a vector element for which the Watermarking Plug-in displays only the vector binary 
watermarking options.
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Glossary

artwork

The elements of design and text that makeup packaging, labels, or other visual media, in which a Digimarc digital 
watermark is or will be included.

barcode

The generic term for an optically machine-readable pattern that encodes data in a way that is generally not 
recognizable to human observation. Barcodes include one-dimensional symbols that encode data into a machine-
readable pattern of adjacent, varying width, parallel, dark rectangular bars and pale spaces, and 2-Dimensional 
Symbols that encode data in the X and Y-axes (sometimes referred to as a 2D barcode), for example, in the case 
of a QR Code, Data Matrix, and Digimarc digital watermarks.

binary pattern

A form of Digimarc Barcode consisting of a sparse pattern of dots.

DeltaE

A measure of how noticeable the difference is between the overlay and the original spot color, where a DeltaE of 
2.3 is barely noticeable and higher DeltaE values are more noticeable. DeltaE is shorthand for the standard CIE 
ΔE*ab, which is the Euclidean distance between two colors in the perceptually uniform device-independent color 
space, CIELAB.

Digimarc Barcode

The Digimarc digital watermark.

Digimarc digital watermark

A novel data carrier that encodes data in media in ways that are generally imperceptible to people, permitting the 
carrier to be repeated many times over the surface of the Enhanced media. It delivers unprecedented ease of use, 
reliability, and efficiency in identifying the media due to massive mathematical and graphical redundancy.

digital twin

A digital counterpart of a physical product comprising events and attributes from and about the product. The 
behavior of the digital twin is customized to deliver an experience that benefits customers and brands across a 
wide variety of digital applications.

digital watermark

In this guide, digital watermark refers specifically to the Digimarc digital watermark.

dot density

The density of dots per tile in a binary pattern expressed as a percentage of a maximum number of waxels that 
contain a dot. The maximum number of waxels that can contain a dot marking in a Tile of a binary pattern is 50%. 
A dot density of 20 means that 10% (20%*50%) of the waxels in a tile contain a dot marking.

dot size

The width of a dot in pixels at the enhancement resolution in binary enhancement. The enhancement resolution is 
expressed in pixels at a resolution in DPI. If the WPI is 75, and the enhancement resolution is 300 DPI, then there 
are 4 by 4 pixels per waxel. Dot size 2, for example, is a dot comprised of two by two pixels.
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minimum dot

The minimum dot percent that can be held at press. Often abbreviated as "min dot." Min dot is affected by factors 
such as the printing process, different plating technologies, and the substrates being printed on. For example, a 
flexographic printer might have a min dot of 2, meaning a 2% dot is the smallest dot they can successfully print at 
press.

negative binary pattern

A sparse pattern of Digimarc Barcode comprised of light dots or holes in a darker background. A Negative Binary 
Pattern is not an inversion of the dark dots in a Positive Binary Pattern of the same Digimarc digital watermark.

positive binary pattern

A sparse pattern of Digimarc Barcode consisting of dark dots on a lighter background. This technique places dark 
dots at the darkest waxels within a tile.

process color

A color comprised of percentages of cyan, magenta, yellow, and black (CMYK) typically printed with halftone 
printing plates. A type of color model, similar to additive color, which involves “process” colors that are a 
combination of cyan, magenta, yellow, and black, or CMYK inks. Each process color is comprised of percentages 
of cyan, magenta, yellow, and black inks. Extended gamut includes additional colors, such as orange, green, and 
violet. From Pantone: achieving color in printing is referred to as CMYK, four–color process, 4/c process or even 
just process. To reproduce a color image, a file is separated into four different colors: Cyan (C), Magenta (M), 
Yellow (Y), and Black (K).

spot color

A color generated by an ink (pure or mixed) that is printed using a single run. This is different from a process color, 
which is produced by overlaying a series of dots on multiple impressions using different colors.

strength

The suggested technique assumes a default strength of 5. Use the slider to view suggestions for other 
enhancement strengths. Some colors can be enhanced better at certain strengths.

substrate

The base material to be printed on.

tile

The fundamental unit of Digimarc watermarks, which is repeated in whole or in part across artwork or a label.

unmarked

Artwork that has not yet been enhanced with a digital watermark.

verification

The process of checking that the data carried in Digimarc digital watermark is both accurate and consistent.

watermarking element

A spatial cell in a tile to which a component of a message and synchronization signal can be mapped. Abbreviated 
as "waxel."
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waxel

A spatial cell in a tile to which a component of a message and synchronization signal may be mapped. Waxel is 
short for "watermarking element."

white ink watermarking

Watermarking white ink is considered an advanced technique that requires specialized training from our Center of 
Digimarc Education.

WPI

The resolution of a Digimarc digital watermark represented as waxels per inch.
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